Les Arbres Web Solutions

Joomla 3

Our extensions require a minimum of Joomla 3.7.0 and we test all our extensions with the latest versions of Joomla as they become available. If you use an older version of Joomla 3 we can provide older versions of our paid extensions on request. We no longer supply versions for Joomla 2.5.

We recommend that you keep your site up to date with the latest version of Joomla. From time to time security issues emerge, and sites that are not updated may be attacked once details of the problem are published. In general you can assume that our extensions work on new releases of Joomla, but if your site is critical to your business you should have a test site where you can test upgrades before implementing them in your live site.

There's a useful table of Joomla versions and support dates at http://docs.joomla.org/Joomla!_CMS_versions

Several users have asked if our extensions are compatible with Joomla 3.10.x. Yes, of course they are!

Joomla 4

All of our extensions have been fully tested and work correctly in Joomla 4.00, and we will continue to test with the latest releases. For the time being we will keep our demo sites running on Joomla 3.

PHP

We develop and test our extensions mainly on PHP 7.4 and 8.0. To maintain backward compatibility we avoid using newer features of PHP and as far as we know our extensions still work on PHP 5.6, although we no longer test on it.

There's a useful table of PHP versions and support dates at https://www.php.net/eol.php. You should be using at least PHP 7.3.

Databases

Our extensions run with MySql and MariaDB. We do not test on SQL Server or PostgreSQL, and we don't allow our extensions to install on them.

Joomla 4 has dropped support for SQL Server, and we expect Joomla to eventually drop support for PostgreSQL.